HTML

Setting Mikrotik Load Balancing Failover Dua Wan



Jika kita mempunyai dua buah koneksi WAN di gabung menjadi satu, maka kita dapat melaksanakan konfigurasi pada router mikrotik semoga terjadi prosedur load balancing. Load balancing di gunakan untuk membagi beban koneksi ke jaringan internet dari link klient. Load balancing akan tetap memakai 2 buah link, bukan menggabungkannya menjadi 1 link bukan menggabung bandwidth lo ya. 

Konsep failover dipakai untuk menjaga semoga koneksi internet tetap terus berjalan manakala salah satu link internet kita mengalami down dengan memakai link yang masih ada.

Langkah Konfigurasi
1. Konfigurasi IP Address
/ip address              add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1 add address=192.168.10.2/224 network=192.168.10.0 broadcast=192.168.10.255 interface=WAN2
2. Konfigurasi VLAN
/interface vlan add name=VLAN-100 interface=LOCAL vlan-id=100 add name=VLAN-200 interface=LOCAL vlan-id=200
/ip address add address=10.10.10.1/24 interface=VLAN-100 add address=10.10.100.1/24 interface=VLAN-200
3. Konfigurasi DNS
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=4.4.4.4,8,8.8.8.8
4. Konfigurasi NAT
/ip firewall nat add chain=srcnat action=masquerade src-address=10.10.10.0/24 out-interface=WAN1 add chain=srcnat action=masquerade src-address=10.10.100.0/24 out-interface=WAN2
5. Konfiguras Mangle untuk IP 10.10.10.0/24 di teruskan ke interface WAN1 dan 10.10.10.0/24 di teruskan WAN2
/ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=WAN1 passthrough=yes src-address=10.10.10.0/24  chain=prerouting action=mark-routing new-routing-mark=WAN2 passthrough=yes src-address=10.10.100.0/24
6. Konfigurasi Routing
/ip route add dst-address=0.0.0.0/0 routing-mark=WAN1 check-gateway=ping distance=1 gateway=192.168.1.1 add dst-address=0.0.0.0/0 routing-mark=WAN2 check-gateway=ping distance=1 gateway=192.168.10.1
add dst-address=0.0.0.0/0 routing-mark=WAN1 check-gateway=ping distance=2 gateway=192.168.10.1 add dst-address=0.0.0.0/0 routing-mark=WAN2 check-gateway=ping distance=2 gateway=192.168.1.1
7. Konfigurasi simple queue per alamat IP Address 10.10.10.2/24
/queue simple Add name="Test1" target-addresses=10.10.10.2/24 interface=VLAN-100 parent=none       packet-marks="" direction=both priority=8       queue=default-small/default-small limit-at=0/0 max-limit=1M/1M       burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s       total-queue=default-small
8. Konfigurasi simple queue per alamat IP Address 10.10.100.2/24
/queue simple Add name="Test2" target-addresses=10.10.100.2/24 interface=VLAN-200 parent=none       packet-marks="" direction=both priority=8       queue=default-small/default-small limit-at=0/0 max-limit=1M/1M       burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s       total-queue=default-small
9. Konfigurasi switch manageable
AccessSwitch>enable AccessSwitch#configuration terminal AccessSwitch(config)#interface fastethernet 0/0 AccessSwitch(config-if)#switchport mode trunk AccessSwitch(config-if)#switchport trunk allowed vlan all AccessSwitch(config-if)#switchport nonegotiate AccessSwitch(config)#vlan 100 AccessSwitch(config)#vlan 200 AccessSwitch(config)#interface fastethernet 0/1 AccessSwitch(config-if)#switchport mode access AccessSwitch(config-if)#switchport access vlan 100  AccessSwitch(config)#interface fastethernet 0/2 AccessSwitch(config-if)#switchport mode access AccessSwitch(config-if)#switchport access vlan 200 AccessSwitch#wr

Nah hingga di sini konfigurasi kita sudah selesai, dari konfigurasi di atas ada kelemahan yakni, jikalau koneksi internet yang mati pada perangkat gatewaynya ibarat DNS down sementara link dari router kita ke gateway baik baik saja  konfigurasi diatas belum dapat mendeteksi. Mungkin ada pembaca yang dapat memberi solusi, sekian terima kasih..


Subscribe to receive free email updates:

0 Response to "Setting Mikrotik Load Balancing Failover Dua Wan"

Posting Komentar