HTML

Perbedaan Srcnat Dan Dstnat Di Mikrotik



Pengertian perihal NAT (Network Address Translation) merupakan metode untuk menghubungkan lebih dari satu IP Address komputer ke jaringan internet dengan menggunakan satu alamat IP. Metode ini di buat alasannya ketersedianan alamat IP yang terbatas di jaringan internet serta kebutuhan kemanan pada jaringan local serta fasilitas dalam sistem manajemen jaringan.

NAT bekerja dengan mengalihkan suatu paket data dari satu IP Address ke alamat IP Address yang lain NAT akan selalu mengingat dari mana asal paket dan kemana tujuan paket dikirimkan, dan ketika ada paket yang kembali maka NAT akan mengirimkannya ke sumber paket. Host dalam jaringan hanya akan mendapatkan paket yang dikirim atau yang diminta sehingga komunikasi sanggup berjalan dengan baik.

Dalam konfigurasi MikroTik ada dua type NAT :

srcnat (Source NAT) : pengalihan dijalankan untuk paket data yang berasal dari jaringan nat. NAT sanggup merubah alamat IP asal paket dari jaringan yang di nat. Source NAT di lakukan sehabis routing dikala sebelum paket keluar menuju jaringan. Masquerade  merukanan perumpamaan dari srcnat.

dstnat (Destination NAT) : pengalihan dikerjakan untuk paket data yang menuju jaringan lokal. Cara ini umum dipakai untuk menciptakan host dalam jaringan lokal sanggup diakses dari  jaringan publik (internet). Destination NAT dilakukan dikala sebelum routing dikala paket sanggup masuk dari jaringan. Port Forward, Port Mapping, transparent proxy ialah perumpamaan dari dstnat.

Kegunaan NAT Pada MikroTik

Source NAT

Apabila ingin menyembunyikan jaringan private LAN kita dengan alamat IP 192. 168. 1. 0/24 dibelakang alamat IP Publik 202. 100. 10. 55 yang didapatkan dari ISP, kita sanggup menggunakan fitur source NAT dengan action masquerade. Masquerade sanggup merubah alamat IP serta port asal (source port) dari paket yang tiba dari jaringan 192. 168. 10. 0/24 ke alamat IP 202. 100. 10. 55 saat sebelum paket keluar dari router.

Misal ketentuan yang sanggup kita gunakan ialah ibarat ini :
/ip firewall nat add chain=srcnat action=masquerade out-interface=public

Semua koneksi yang keluar dari jaringan 192. 168. 10. 0/24 sanggup mempunyai satu alamat IP yang sama yakni 202. 100. 10. 55 

Destination NAT

Apabila kita ingin menghubungkan satu alamat IP lokal 192. 168. 10. 30 semoga sanggup diakses dari jaringan internet lewat IP Publik 202. 100. 10. 55, jadi kita sanggup menggunakan fitur destination NAT.

Konfigurasi IP address publik ke interface publik :
/ip address add address=202. 100. 10. 55/32 interface=publik

Lalu buat ketentuan dengan destination NAT, server internal sanggup dibuka :
/ip firewall nat add chain=dstnat dst-address=202. 100. 10. 55 action=dst-nat to-address=192.168. 10.30

Kebalikannya untuk ketentuan server internal sanggup bicara dengan jaringan luar yang akan dialihkan ke IP Publik 202. 100. 10. 55 :
/ip firewall nat add chain=srcnat src-address=192. 168.10. 30 action=src-nat to address=202. 100. 10. 55

Dengan sekenario di atas setiap paket yang menuju jaringan lokal lewat alamat IP Publik 202. 100. 10. 55 dapat diarahkan ke alamat IP lokal 192. 168. 10. 30. Begitupun demikian sebaliknya tiap-tiap paket yang tiba dari alamat IP lokal 192. 168. 10. 30 sanggup ditukar dengan alamat IP Publik 202. 100. 10. 55 jadi IP Publik sanggup melanjutkan paket dari 192. 168. 10. 30 ke jaringan internet.

Mapping 1 : 1

Jika kita ingin menghubungkan IP Publik dengan subnet 10. 10. 10. 0/24 ke IP lokal dengan subnet 192.168.100. 0/24, Kita gunakan destination NAT dengan action netmap.

Berikut misalnya :
/ip firewall nat add chain=dstnat dst-address 10. 10. 10. 0/24 action=netmap to-address=192. 168. 100. 0/24
/ip firewall nat add chain=srcnat dst-address 192. 168. 100. 0/24 action=netmap to address=10. 10. 10. 0/24

Port Mapping

Kita sanggup juga mengalihkan usul port tertentu ke server internal didalam jaringan. hal ibarat ini sering dipakai untuk membuka port tertentu:

Berikut misalnya :
/ip firewall nat add chain=dstnat protocol=tcp dst-port=80 in-interface=local action=dst-nat to-address=192. 168. 1. 1 to-port=80

Perintah diatas mengalihkan seluruhnya paket yang menuju port 80 yang menggunakan protokol tcp yang masuk melalui interface local ke alamat IP Address 192. 168. 1. 1 port 80.

Subscribe to receive free email updates:

0 Response to "Perbedaan Srcnat Dan Dstnat Di Mikrotik"

Posting Komentar